logo

Member
Member
Offline Offline
Posts: 46
Figured I'd say hi to you all again...

Started yesterday on a reskin of the entire admin interface.

I saw the premise behind Xaphire, regarding how it operates, and using it as an idea starter, and running with it.

Thus far:
I've created a 'button bar' across the top of the admin panel
It contains all 13 standard admin links, as 60x60 rounded-corner box images.
I have a label above it, that changes to whatever you're mousing over, or what page you're on if you're not mousing over an icon.
Behind it, I have a rounded-corner 'shiny' black box.

I used the 'shiny' (Dark bottom, light top gradient) as inspiration for new sub-panel headers, and started reworking them.

I've created a gray rounded scheme for the admin panel contents, which I'm setting to hover just below their title.

I'm half through redesigning the forums admin page. Though I was inspired to the idea by Xaphire, I'm using the default template as base code. For now, I'm creating a monolithic php file, which is controlled by a switch statement.

Once I get the first page redesign done, I might even be inclined to show you all a screen shot. Wink

Now, its time for bed.

Oh, and one little thing that irked me... if I do this:
Code:

$head = '<script>some script</script><script>another script</script>';
switch ($title) {
case ("Forums"):
   $head .= '<script>a third script</script><script>yet another script</script>';
break;
}

..then this...
Code:

<script>a third script</script><script>yet another script</script>

...is printed verbatim in the 'error' area, like it's not getting interpreted right. Looking at page source, it LOOKS right, but instead of getting read as 'load this script' its simply displaying it.

Now, if I do this...
Code:

switch ($title) {
case ("Forums"):
   $head = '<script>some script</script><script>another script</script><script>a third script</script><script>yet another script</script>';
default:
   $head = '<script>some script</script><script>another script</script>';
break;
}

..it works, but it's redundant.

I even tested it by a simple concat equals, like so:
Code:

   $head = '';
   $head .= '<script>some script</script><script>another script</script>';

..which broke and simply displayed the scripting, which was supposed to be interpreted.

I didn't poke too much yet at why, so it may have been something I broke, but I am throwing it out there since I noticed it. I'll probably look at it after the redesign (when I go to trim it down).
eoCMS Designer
eoCMS Designer
Offline Offline
avatar
Posts: 1290
tbarkass_willamson@hotmail.com
Re: Figured I'd say hi to you all again...

Sounds good. Can we see a screenshot? Smile

Seen a bug? Report it!
eoCMS Designer
eoCMS Designer
Offline Offline
avatar
Posts: 291
haz_pwnd_u@yahoo.com
Re: Figured I'd say hi to you all again...

Sounds good. Can we see a screenshot? Smile

He said once he finishes the first page redesign done Tongue
Member
Member
Offline Offline
Posts: 46
Re: Figured I'd say hi to you all again...

Well, I'm getting there. It'd bed time, and I've more or less finished the Forums page... formatting is easy enough (now that I'm happy with graphics)... however getting functionality split correctly is being a PITA.

Remember, I'm trying to make it stick to a monolithic php file for the entire admin interface... because of this, handling _POST and whatnot is proving to be a real pain... especially since I'm using the Default template as a coding guideline... separating things out is annoying.

Without further ado, here's my work thus far:

http://i59.photobucket.com/albums/g286/Felyza/current.png
Last Edit: 22nd September, 2009, 06:15:19 AM by FWishbringer
Member
Member
Offline Offline
Posts: 46
Re: Figured I'd say hi to you all again...

You know, looking at it again today, I think I may just change the way the permissions work, and make it a couple of multiple selection list boxes.
eoCMS Designer
eoCMS Designer
Offline Offline
avatar
Posts: 1290
tbarkass_willamson@hotmail.com
Re: Figured I'd say hi to you all again...

Looks good Smile.

Seen a bug? Report it!
Member
Member
Offline Offline
Posts: 144
Re: Figured I'd say hi to you all again...

Nice work Wink

Jump to:


0.05 seconds Queries: 13